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Warranty 2

Tektronix warrants that this product will be free from defects in materials and workmanship for a period of one (1) year from the date 
of shipment. If any such product proves defective during this warranty period, Tektronix, at its option, either will repair the defective 
product without charge for parts and labor, or will provide a replacement in exchange for the defective product. Parts, modules and 
replacement products used by Tektronix for warranty work may be new or reconditioned to like new performance. All replaced parts, 
modules and products become the property of Tektronix.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the warranty period 
and make suitable arrangements for the performance of service. Customer shall be responsible for packaging and shipping the 
defective product to the service center designated by Tektronix, with shipping charges prepaid. Tektronix shall pay for the return of 
the product to Customer if the shipment is to a location within the country in which the Tektronix service center is located. Customer 
shall be responsible for paying all shipping charges, duties, taxes, and any other charges for products returned to any other locations.

This warranty shall not apply to any defect, failure or damage caused by improper use or improper or inadequate maintenance and 
care. Tektronix shall not be obligated to furnish service under this warranty a) to repair damage resulting from attempts by personnel 
other than Tektronix representatives to install, repair or service the product; b) to repair damage resulting from improper use or 
connection to incompatible equipment; c) to repair any damage or malfunction caused by the use of non-Tektronix supplies; or d) to 
service a product that has been modified or integrated with other products when the effect of such modification or integration 
increases the time or difficulty of servicing the product. 

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PRODUCT IN LIEU OF ANY OTHER WARRANTIES, 
EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX' RESPONSIBILITY TO REPAIR OR REPLACE DEFECTIVE PRODUCTS 
IS THE SOLE AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY. TEKTRONIX 
AND ITS VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES 
IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS ADVANCE NOTICE OF THE POSSIBILITY OF SUCH 
DAMAGES.
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General Safety Summary
General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it. 
To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

To Avoid Fire or Personal Injury

Use Proper Power Cord. Use only the power cord specified for this product and certified for the country of use.

Ground the Product. This product is grounded through the grounding conductor of the power cord. To avoid electric 
shock, the grounding conductor must be connected to earth ground. Before making connections to the input or output ter-
minals of the product, ensure that the product is properly grounded.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product. Consult 
the product manual for further ratings information before making connections to the product.

Power Disconnect. The power cord provides Mains disconnect.

Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it inspected by 
qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.

Do Not Operate in Wet/Damp Conditions. 

Do Not Operate in an Explosive Atmosphere. 

Keep Product Surfaces Clean and Dry. 

Provide Proper Ventilation. Refer to the manual’s installation instructions for details on installing the product so it has 
proper ventilation.
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General Safety Summary
Terms in this Manual

These terms may appear in this manual:

Symbols and Terms on the Product

These terms may appear on the product:

■ DANGER indicates an injury hazard immediately accessible as you read the marking.

■ WARNING indicates an injury hazard not immediately accessible as you read the marking.

■ CAUTION indicates a hazard to property including the product.

The following symbols may appear on the product:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that result in damage to this product or other property.

CAUTION
Refer to Manual

WARNING
High Voltage

Protective Ground
(Earth) Terminal

Earth Terminal Chassis Ground Standby
iv AWG5000 Series Quick Start User Manual
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Environmental Considerations

AWG5000 Series Quick Start User Manual v

Environmental Considerations
This section provides information about the environmental impact of the product.

Product End-of-life Handling

Observe the following guidelines when recycling an instrument or component.

Equipment Recycling. Production of this equipment required the extraction and use of natural resources. The equip-
ment may contain substances that could be harmful to the environment or human health if improperly handled at the 
product’s end of life. In order to avoid release of such substances into the environment and to reduce the use of natural 
resources, we encourage you to recycle this product in an appropriate system that will ensure that most of the materials 
are reused or recycled appropriately.

The symbol shown to the left indicates that this product complies with the 
European Union’s requirements according to Directive 2002/96/EC on 
waste electrical and electronic equipment (WEEE). For information about 
recycling about options, check the Support/Service section of the 
Tektronix Web site (www.tektronix.com).

Mercury Notification. This product uses an LCD backlight lamp that contains mercury. Disposal may be regulated due 
to environmental considerations. Please contact your local authorities or, within the United States, the Electronics Indus-
tries Alliance (www.eiae.org) for disposal or recycling information.

Restriction of Hazardous Substances

This product has been classified as Monitoring and Control equipment, and is outside the scope of the 2002/95/EC RoHS 
Directive. This product is known to contain lead, cadmium, mercury, and hexavalent chromium.
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Preface
Preface
This manual describes the installation and operation of AWG5000 series instruments. Basic operations and concepts are 
presented in this manual. For more detailed information, see the online help on your instrument. The following instruments 
are supported by this manual:

■ AWG5012

■ AWG5014

■ AWG5002

■ AWG5004

Key Features
The following table and list describe the key features of the AWG5000 series instruments.

■ Windows XP Professional operation system

■ Up to 32,400,000 memory length (Option 01)

■ 28 bits digital data output (Option 03, AWG5012 and AWG5002 only)

■ A large 10.4 inch (264.2 mm) high resolution XGA color display

■ An intuitive, graphical user interface (UI), with built-in online help

■ 80 GB hard disk drive

■ CD-RW/DVD

■ Supports USB 2.0 interface

■ LAN (1000/100/10 Base-T)

■ Touch screen user interface

Model AWG5012 AWG5014 AWG5002 AWG5004

Maximum Sampling Rate 1.2 GS/s 600 MS/s

D/A Resolution 14 bits

Memory Length 16,200,000 or 32,400,000 (Option 01)

Analog Output 2 4 2 4

Maximum Amplitude and 
Analog Bandwidth

2.0 Vp-p, 250 MHz (Direct Output: Off)
0.6 Vp-p, 370 MHz (Direct Output: On)

Marker Output (2/channel) 4 8 4 8

Digital Data Output 28 bits (Option 03) N/A 28 bits (Option 03) N/A
AWG5000 Series Quick Start User Manual vii
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Preface
Documentation
Additional information is available through a variety of sources. Review the following table to locate more information about 
this product.

Conventions Used in this Manual
The following icons are used throughout this manual.

To read about Use these documents

Installation and Operation (overviews) Read the Quick Start User Manual for general information about how to use 
your instrument.

In-depth Operation and User Interface Help Access the user online help from the Help menu for information on virtually all 
controls and elements on screen. Online help includes detailed instructions 
for using instrument functions. (See page 10, Accessing Online Help.)

Programmer Commands Access the programmer online guide from the Help menu. The programmer 
guide includes the syntax of remote commands.

Specifications and Performance Verification 
Procedures

Read the Technical Reference for specifications and the performance verifi-
cation procedure. The Technical Reference PDF file is on the Document CD.

1

Sequence
Step

Front panel
power

Connect
power

Network PS2 SVGA USB
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Install Your Instrument
Install Your Instrument
Unpack the instrument and check that you received all items listed as Standard Accessories. Recommended accessories 
and instrument options are listed in the online help. Check the Tektronix Web site (www.tektronix.com) for the most current 
information.

Standard Accessories

Accessory Tektronix part number

AWG5000 series Arbitrary Waveform Generators Quick Start User Manual

English (Option L0) 071-2078-xx

Japanese (Option L5) 071-2079-xx

Simplified Chinese (Option L7) 071-2080-xx

Traditional Chinese (Option L8) 071-2081-xx

Operating System Restore DVD 020-2762-xx

Product Software CD 020-2763-xx

Document CD 063-3994-xx

User Online Help (part of the product software) –––

Programmer Online Help (part of the product software) –––

1 Windows compatible keyboard 119-7083-00

1 Windows compatible mouse 119-7054-00

2 Stylus pens 119-6107-00

Lead Set for DC Output 012-1697-00

Front Protect Cover 200-4963-00

Accessory Pouch 016-1441-01

Power cord – one of the following:

North America (Option A0) 161-0104-00

Universal Euro (Option A1) 161-0104-06

United Kingdom (Option A2) 161-0104-07

Australia (Option A3) 161-0104-14

Switzerland (Option A5) 161-0167-00

Japan (Option A6) 161-A005-00

China (Option A10) 161-0306-00

India (Option A11) 161-0324-00

No power cord or AC adapter (Option A99) –––
AWG5000 Series Quick Start User Manual 1
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Install Your Instrument
Operating Requirements

Power Supply Requirements

Cleaning

Inspect the arbitrary waveform generator as often as operating conditions require. To clean the exterior surface, perform 
the following steps:

1. Remove loose dust on the outside of the instrument with a lint-free cloth. Use care to avoid scratching the front panel 
display.

2. Use a soft cloth dampened with water to clean the instrument. Use an aqueous solution of 75% isopropyl alcohol for 
more efficient cleaning.

1. Place the instrument on a cart or bench, 
observing clearance requirements:

■ Top: 20 mm (0.8 in)

■ Left and right side: 150 mm (5.9 in)

■ Bottom: 20 mm (0.8 in)

■ Rear: 75 mm (3 in)

2. Before operating, ensure that the 
ambient temperature is between 10 °C 
and 40 °C (+50 °F to +104 °F).

CAUTION. To ensure proper cooling, keep sides of the instrument clear of obstructions.

AWG 5014 1.2 GS/sArbitrary Waveform Generator

Analog Analog Mkr 1 Mkr 2 Analog Analog Mkr 1 Mkr 2 Analog Analog Mkr 1 Mkr 2 Analog Analog Mkr 1 Mkr 2
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GND

 465 mm
(with handle)

245 mm

Source Voltage and Frequency 100 VAC to 240 VAC, 47 Hz to 63 Hz

Power Consumption Less than 560 W

WARNING. To avoid personal injury, power down the instrument and disconnect it from line voltage before performing any 
of the following procedures.

CAUTION. To avoid damage to the surface of the arbitrary waveform generator, do not use any abrasive or chemical clean-
ing agents.
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Install Your Instrument
Powering On the Instrument

Powering Off the Instrument

1. Connect the AC power cord to the rear 
of the instrument.

2. Use the front-panel power button to 
switch the instrument on.

1. Use the front-panel power button to 
start the shutdown process.

Wait approximately 30 seconds for the 
instrument to power off.

2. To completely remove power to the 
instrument, perform the shutdown just 
described, and then remove the power 
cord from the instrument.

~100-240 V
47-63 Hz

560 Watts

To avoid electric shock
the power cord protective
grounding conductor
must be connected to
ground. No operator
serviceable components
inside. Do not remove
covers. Refer servicing
to qualified personnel. 
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Install Your Instrument
Windows Interface Guidelines
Because the instrument uses the Microsoft Windows interface, you have open access to the Windows operating system. 
You can access the Windows desktop to load and run other Windows-based applications such as Microsoft Excel, Word-
Pad, and Paint.

Although you have access to the Windows interface, you should avoid making operating system changes that may cause 
problems or annoyances while trying to use the instrument. Here are some guidelines:

■ Be careful when making changes in the Control Panel. Avoid making changes to any controls with which you are 
unfamiliar.

■ Do not delete or change any system fonts. Changing or removing fonts may affect the quality of the display.

■ Avoid changing the system Display Properties, such as the Background, Appearance, Effects, or Settings. Making such 
changes can affect the usability of the instrument and the touch screen.

■ Avoid making changes to the contents of the Windows folder or to the contents of the Program Files\Tektronix\AWG\ 
System folder.

■ Avoid making changes to the BIOS settings. Changing the BIOS settings can affect the overall operation of the 
instrument.

If you think that your Windows interface may cause problems with the instrument, contact your local Tektronix support 
center for assistance.
4 AWG5000 Series Quick Start User Manual
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Install Your Instrument
Connecting to a Network
You can connect your instrument to a network for printing, file sharing, internet access, and other functions. Consult with your 
network administrator and use the standard Windows utilities to configure the instrument for your network.

For setting GPIB or LAN configuration, use the GPIB/LAN Configuration dialog box from System menu. See page 68.

Controlling the instrument using a remote PC
You can use your PC to control the arbitrary waveform generator through a LAN using the Windows Remote Desktop func-
tion. If your PC has a larger screen, you can edit waveforms easily using your keyboard and mouse. You can also use a 
third party software installed on your PC to create a waveform and import it through a network.
AWG5000 Series Quick Start User Manual 5
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Install Your Instrument
Offline Mode
The Offline Mode is a function that you can use to run the instrument application on your PC. Install the application on your 
PC; the instrument hardware is not required. You can create and edit the instrument setups. The setup files that you create 
can be used later with your arbitrary waveform generator.

1. Use the Product Software CD provided 
with the instrument to install the 
AWG5000 series application to your 
PC.

2. Before using the offline mode, you must 
set up the instrument configuration.

From the Windows Start menu, select 
All Programs > Tektronix > AWG > 
Config Utility. The Configuration Utility 
dialog box appears.

3. Select your instrument type.

4. Select your instrument option configura-
tion.

5. Click OK. 

Run the instrument application from the 
Start menu. The setup configuration 
you have made using the Configuration 
Utility will be reflected in the application.

1

2

4

3

5
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Install Your Instrument
Inspect Your Instrument
Two types of diagnostics are provided to verify the functionality of your instrument:

■ Power-on self test – Every time you power on the instrument, the instrument automatically performs the internal 
diagnostics.

■ Diagnostics from the System menu – You can also run the internal diagnostics using the System menu. Use the 
following procedures:

1. Select System > Diagnostics... from the 
menu bar.

The Diagnostics dialog box appears.

2. Confirm that the Loop box is not 
checked.

If Loop is checked, the diagnostics runs 
until it is manually stopped.

3. If you click Select All, all diagnostic 
items are checked.

You can execute all items together or 
you can execute only the selected 
item(s).

4. Click Execute to start the diagnostics.

Verify that the instrument passes all 
tests. If diagnostic failures occur, 
contact your local Tektronix service 
personnel.

1

2

3

4
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Install Your Instrument
Self Calibration
The self calibration uses internal calibration routines that check electrical characteristics such as analog level accuracy, 
and then adjust the internal calibration constants as necessary.

NOTE. Power on the instrument and allow a 20 minute warm-up period before performing this procedure.

1. Confirm that there is no output signal by 
verifying that the front-panel Run button 
indicator is off.

2. To perform the calibration suite, select 
System > Calibration... from the menu 
bar. 

The Calibration dialog box appears.

3. Select Execute. 

4. A pop-up message asks you to remove 
all the cables from the Analog output 
connectors.

5. Remove the cables and then select OK. 
Wait until the calibration completes.

For all calibration items, the Status con-
trol should indicate Pass. If it does not, 
contact your local Tektronix service per-
sonnel.

NOTE. Self calibration is not valid until the instrument reaches a valid temperature. See page 2 for operating requirements.

NOTE. Perform self calibration once a year to maintain the analog output level accuracy.

RunRunRunRunRunRun 1

2

3

4

5
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Install Your Instrument
Preventing Instrument Damage

Overheat Protection

The internal instrument temperature is monitored and the instrument is protected against overheating damage by the 
following actions:

■ A warning message will appear if the internal temperature reaches the first threshold level.

■ The instrument will shut down if its temperature reaches the second threshold level.

If the warning message appears or the instrument shuts down, check for the following conditions (see page 2 for operating 
requirements):

■ The ambient temperature requirement is not being met.

■ The required cooling clearance is not being met.

■ The instrument fan is not working properly.

Output Connectors

The arbitrary waveform generator has both output and input connectors on the front panel. Do not apply external voltage 
to the output connectors.

To prevent damage to the instrument, do not apply external 
voltages to the output connectors.

CAUTION. Always turn off the signal outputs when you connect or disconnect cables to/from the signal outputs connectors. 
If you connect a DUT while the instrument signal outputs are in the On state, it may cause damage to the instrument or 
DUT.
AWG5000 Series Quick Start User Manual 9
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Install Your Instrument
Accessing Online Help
The arbitrary waveform generator provides two types of online help:

■ User online help – In-depth information is available in the online help on all the features of your instrument.

■ Programmer online help – The instrument offers programmer online help about remote commands.

Quick Tips

■ You can select English or Japanese for the user online help. By default, English is selected. To change the language, 
use the System menu > Preferences dialog box. See page 69.

■ The programmer online help is displayed only in English.

To access the Help system, select Help from 
the menu bar.

1. To access the user online help, select 
Help > Help Topic....

2. To use context-sensitive help on the 
current setup, select Help > Help on 
Window... or press F1.

3. To access Programmer Online Help, 
select Help > Help on Remote 
Commands....

4. To access specifications and perfor-
mance verification, select Specifica-
tions... to open the PDF Technical 
Reference Manual.

5. Most dialog boxes have a Help button. 
For contextual overviews of the dialog 
box, click the button to open the help 
system with an overview of the dialog 
box that is currently displayed.

NOTE. When you first open the Japanese user online help, a pop-up message is displayed to prompt you to install the 
Japanese language pack. Click Install to install the language pack.

3
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Front Panel
Front Panel
The following figure shows the front panel of the AWG5014:

Front Panel Connectors

Connector Description

1. Ch 1 Analog Output These connectors supply analog signals.
Connector type: BNC

2. Ch 1 Marker Output These connectors supply marker 1 and marker 2 signals.
Connector type: BNC

3. Ch 2 to Ch 4 connectors Analog and marker output connectors for Ch 2 to Ch 4.

4. Trigger Input External trigger signal is applied to this connector.
Connector type: BNC

5. Event Input Event signal is applied to this connector.
Connector type: BNC

6. USB Two USB connectors are present on the front panel.
Connect a USB device.

7. DC Output This connector supplies four lines of DC voltage.
Connector type: 2.54 mm 2 x 4 pin header (female)
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CAUTION. Always turn off the signal outputs when you connect or disconnect cables to/from the signal outputs connectors. 
If you connect a DUT while the instrument signal outputs are in the On state, it may cause damage to the instrument or 
DUT.
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Rear Panel
Rear Panel

Rear Panel Connectors

Connector Description

1. 10 MHz Reference Output Output connector for 10 MHz reference clock signal
Connector Type: BNC

2. Reference Clock Input Input connector for external reference clock
Connector Type: BNC

3. Oscillator Output Output connector for internal oscillator
Connector Type: BNC

4. External Clock Input Input connector for oscillator input
Connector Type: BNC

5. Add Input Add external signal to the output signal of arbitrary waveform generator
Connector Type: BNC

6. GPIB Use the GPIB connector to connect the instrument to a GPIB controller for GPIB opera-
tion.

7. LAN Use the RJ-45 connector to connect the instrument to a network.

8. Parallel Port Use the parallel port (Centronics) to connect a printer or other device.

9. USB Use the USB connectors to connect a USB mouse, keyboard, or other USB device to the 
instrument.

10. Video Use the Video port to connect a monitor for extended desktop operation.

11. COM1 Use the COM1 serial port to connect to other devices through the serial port.

12. PS-2 connector Use the PS-2 connectors to connect a PS-2 keyboard or mouse to the instrument.

13. Removable HDD Removable hard disk drive to secure data

14. Digital Data Out Use these connectors to output digital data. To enable digital data output, option 03 must 
be installed in the AWG5002 or AWG5012.
Connector Type: SMB

15. This connector is not supported.
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Control Panel
Control Panel
The following figure shows the front panel controls of a four channel model:

Run. The Run button is used to start and stop the signal generation. If the signal is being generated, the LED indicator 
lights up. To output the signal through the output connectors, you must push the front-panel All Outputs On/Off button or 
the Channel Output On button. 

Touch Screen Off. When the Touch Screen is on, you can use your finger or stylus to control the screen interface. The 
LED is lit while the Touch Screen interface is disabled. 

File Open/Save. When the Open or Save button is pushed, the corresponding dialog box is displayed. You can load or 
save a setup (*.AWG) file using this dialog box.

Factory Default. When this button is pushed, the specified default setups are recalled. See page 32 for details on default 
setups.

Timing – Sampling Rate. When you push this button, the sampling rate parameter in the Settings window is selected. 
Sampling Rate is common to each channel. See page 26 for Settings window.

Channel Select. These buttons are used to select a channel that you want to interact with. If a channel select button on 
the front panel is pushed, the selected channel page in the Settings Window will be activated. 

Channel Output On. These buttons are used to enable/disable the channel output. If the output is in the On state, the 
LED is turned on.

Run button

Channel Output On 
button

Channel Select 
button

General Purpose knob

Digit Selection 
keys

CAUTION. Do not connect a DUT (Device Under Test) to the front-panel signal output connectors when the instrument 
signal outputs are on.

Do not power on or off the DUT when the arbitrary waveform generator signal outputs are on.
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Control Panel
All Outputs On/Off. If one or more Outputs are on, they will all be turned off when you push the All Outputs On/Off but-
ton. If all Outputs are off, they will all be turned on when you push the All Outputs On/Off button.

Amplitude. When you push this button, the amplitude parameter of the corresponding channel in the Settings window is 
selected. Amplitude is independent for each channel. 

Offset. When you push this button, the offset parameter of the corresponding channel in the Settings window is selected. 
Offset is independent for each channel. 

Marker 1 and Marker 2 – High/Low. When you push one of these buttons, the Marker High or Marker Low parameter 
of the corresponding channel in the Settings window is selected. Marker High and Marker Low are independent for each 
channel.

Force Trigger. When you push this button, the instrument generates an internal trigger signal.

Force Event. When you push this button, the instrument generates an internal event signal.

General Purpose Knob. The knob is used to increase or decrease a set value or select an item from a pop-up menu, 
pull-down menu or dialog box. Turn the knob clockwise to increase the value, and turn the knob counterclockwise to 
decrease the value.

Digit Select Arrow Keys. The digit select arrow keys are used to move the under bar (cursor) to a field that contains an 
editable number. After you specify the digit, you can change the number with the knob.

Numeric Keypad. Units prefix buttons (T/p, G/n, M/μ, and k/m) are used to complete an input with the numeric keypad. 
You can determine the units by pushing one of these prefix buttons without pressing the Enter key.

If you push the units prefix buttons for frequency, the units are interpreted as T (tera-), G (giga-), M (mega-), or k (kiro-). If 
you push the buttons for time, the units are interpreted as p (pico-), n (nano-), μ (micro-), or m (milli-).
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Control Panel
To Lock/Unlock the Front Panel Controls
The front panel may be locked by a remote user while the arbitrary waveform generator is being remotely controlled via 
GPIB or Ethernet. When the front panel is locked, all keys and buttons are disabled except the power switch. You cannot 
use your mouse or keyboard. However, the Windows operations are available even if the instrument front panel is locked.

To unlock the front-panel controls, use a remote command or push the front-panel Cancel button twice. If you exit the appli-
cation, the lock state is cleared. When you restart the application, the front-panel controls are unlocked.

Touch Screen Interface
The arbitrary waveform generator offers two methods of making menu selections:

■ Front-panel controls, keyboard, and mouse (keyboard and mouse are standard accessories)

■ Front-panel controls and touch screen interface

1. You can enable or disable the touch 
screen interface by pushing the 
front-panel Touch Screen button.

To disable the touch screen, push the 
front-panel Touch Screen button. When 
the touch screen is in the Off state, the 
LED is lighted. You can still access the 
on-screen menus with a mouse or key-
board.

NOTE. You need to adjust the touch screen when one of the following occurs:

■ The operating system is restored

■ The hard disk drive is exchanged

■ The touch screen is not responding correctly

Run the touch screen program from the shortcut on the Windows desktop to adjust the touch screen.

1
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Control Panel
Changing Control Settings
As you configure the instrument, you may need to set a numerical parameter such as an amplitude level or offset. To set 
these parameters in a screen window, touch or click the parameter to select it. Once the parameter is selected, the general 
purpose knob is assigned to the parameter. 

You can use the general purpose knob to change parameters, although the following methods are generally available.

Quick Tip

■ The pop-up keyboard and keypad are also called soft keyboard and soft keypad, respectively.

1. Some parameters have increase/ 
decrease buttons. These buttons are also 
called spin buttons. Touch or click the 
spin buttons to change to the next avail-
able value.

To move the underbar to a field that 
contains an editable number, use the digit 
select arrow keys (see page 14).

2. Some parameters supply a pop-up 
keypad or keyboard that you can use to 
enter a new value. 

Touch or click the keypad (or keyboard) 
icon to display the keypad (or keyboard).

1
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Control Panel
Run State Control and Output On/Off
Do the following steps to control the start and stop of signal generation for the arbitrary waveform generator.

Quick Tips

■ You can turn each channel’s output on/off independently.

■ Analog output and marker output are enabled or disabled simultaneously.

1. Use the front-panel Run button to start 
and stop the signal generation.

Switching signal generation on or off is 
called Run State control.

If the signal is being generated, the LED 
indicator lights up.

2. To output the signal through the output 
connectors, push the front-panel All 
Outputs On/Off button or the Channel 
Output On button.

3. Alternatively, you can use the Ch n 
(Channel) tab on the Settings window to 
enable the signal output. See page 26 
for Settings Window.

1
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Interface and Display
Interface and Display
The screen interface gives you access to the complete functionality of the instrument. This user interface is built on the 
Windows operating system.

Screen Interface

Menu Bar. The menu bar provides access to all of the instrument functions. When you select a menu item, the instrument 
displays the associated control window (dialog box) or the menu selection causes an immediate action.

Status Bar. The status bar, located below the menu bar, shows information about the instrument, such as sampling rate, 
run mode status, or output status.

Waveform List Window. User-defined waveforms and predefined waveforms are listed in this window.

Sequence Window. This window mainly provides information on output sequence.

Waveform Window. This window displays the waveform that you selected in the Waveform List or in the Sequence 
window.

Settings Window. This window is provided for quick access to the parameter settings.

Window Tag. Click these tags to toggle display of corresponding windows on or off.

Remote Command Bar. In this area, a remote command corresponding to current instrument operation is displayed.

Menu bar

Sequence 
window

Window 
tag

Remote Command 
bar

Status bar

Waveform
 window

Settings
 window

Waveform
List window
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Interface and Display
Basic Steps for Using the Arbitrary Waveform Generator
After you have powered on the instrument, use the application’s menu bar or control windows to create and edit a wave-
form. For accessing menus and control windows, see page 20. Do the following steps to output a waveform or a sequence:

Quick Tips

■ The arbitrary waveform generator supports four types of Run mode. When Run mode is set to Continuous, Triggered, 
or Gated, the state is called non-sequence mode.

■ You can select one waveform as an output for each channel in the non-sequence mode.

1. To create a new waveform, select Edit 
> Standard Waveform.... The created 
waveform is displayed in the Waveform 
List window.

2. To use an existing waveform, select 
File > Open File... to open a setup file, 
and then select a waveform in the 
Waveform List window.

3. Confirm the Run mode. Check that the 
desired run mode is selected on the 
Run Mode tab of the Settings window.

4. To generate a signal, push the 
front-panel Run button or the Run 
button on the Status Bar.

5. Use one of the following methods to set 
the channel output On:

■ Front-panel Channel Output On 
button or All Outputs On/Off button

■ Output On button of the Ch page of 
Settings window

1
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Interface and Display
Accessing Menus and Control Windows
You can access menu commands and control windows using the following techniques:

1. Click Settings from the menu bar, and 
then select a command.

The selected item in the Settings window 
will become active.

2. For a shortcut to settings menus, you 
can use the Settings window.

Clicking a tab, such as Ch 1 or Timing, 
on the Settings window opens the 
corresponding page that you can use to 
select the instrument settings.

3. From the front panel, you can quickly 
access the parameters for sampling 
rate, amplitude level, offset level, and 
marker level.

If you push one of these buttons, the 
corresponding parameter in the Set-
tings window will be selected.

4. You can right-click the mouse to gain 
quick access to associated menu 
commands.

For example, right-click on the Wave-
form List window to display the related 
Edit menu commands.

1
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Interface and Display
Display/Hide Control Windows
The arbitrary waveform generator displays four control windows by default. You can quickly hide or display each window 
using the window tag.

1. By default, four windows are displayed 
if the Run mode is Sequence.

2. Click the Waveform List tag.

3. The Waveform List window is hidden.

1

3
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Interface and Display
Status Bar
Status Bar has two functions. It displays the current status of the instrument, such as Sampling Rate, Run State, and Run 
Mode. It also has action buttons, such as Force Trigger, Force Event, All Outputs On/Off, and Run.

1. Sampling Rate Current sampling rate setting is displayed.

2. Run Status Current instrument status (Running or Stopped) is displayed.

3. Run Mode Current Run Mode (see page 29) is displayed.

4. Force Trigger button Same function as the front-panel Force Trigger button.

5. Force Event button Same function as the front-panel Force Event button.

6. All Outputs On/Off button Same function as the front-panel All Outputs On/Off button.

7. Run button Same function as the front-panel Run button.

DIsplays instrument status Use these buttons to cause an action

71 2 3 4 5 6
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Interface and Display
Waveform List Window
The Waveform List window lists the waveforms that are saved in the setup files (*.AWG). The instrument provides two types 
of waveform list (predefined and user-defined).

Quick Tips

■ If you right-click on this window, a pop-up menu is displayed. You can access the Edit commands, such as Delete, Copy, 
and Paste.

■ When you create a waveform, you cannot use the same name as a predefined waveform.

1. To select a predefined waveform, click 
the Predefined tab.

2. Predefined waveforms have an asterisk 
sign (*) to the left of the waveform 
name.

Note: You cannot modify, delete, or rename the 
predefined waveforms.

3. To select a user-defined waveform, 
click the User Defined tab.

4. You can sort the waveform list by the 
order of Waveform Name, Length, or 
Date.

5. Each waveform length is displayed as a 
three-digit number in the Waveform List 
window.

6. If you want to know the exact waveform 
length, select the waveform and then 
right-click to display the pop-up menu. 
Select Waveform Properties... to 
display the Waveform Properties dialog 
box. You can confirm the waveform 
length with this dialog box.

2
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Interface and Display
Sequence Window
When Sequence is selected in the Run Mode, this window shows information on the status of the sequence settings. For 
Run Mode, see page 29.

Quick Tips

■ If you click on a cell in the Sequence window, the selected waveform is displayed in the Waveform window. The 
background color of the selected cell changes.

■ The following methods are available for applying an existing waveform to a sequence:

■ Drag a waveform from the Waveform List window to a cell of the Sequence window

■ After selecting a cell in the Sequence window, use Set Waveform... or Insert Waveform... from the Edit menu

■ When Continuous, Triggered, or Gated is selected in the Run mode, the Sequence window is hidden.

■ The following icons are used in the Sequence window:

1. This is an example of the Sequence 
window display. The display format is 
Thumbnail.

If you hover the mouse over a sequence 
cell, a tooltip appears to show you the 
waveform name and waveform length.

2. This is an example of the Table format.

Display Icons Description

Wait Trigger

Repeat. (Repeat count is set to 26 in this example.)

Repeat (Infinite)

Event Jump. (Jump target is set to index number 26 in this example.)

Go To (Go To target is set to index number 26 in this example.)

1

2
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Interface and Display
Waveform Window
A selected element in the Sequence window or a selected waveform on the Ch n page of the Settings window is displayed 
in the Waveform window.

Quick Tips

■ You can change the display format of the Sequence window or the Waveform window using the View menu > Display 
Properties dialog box. You can also access the Display Properties dialog box by right-clicking on the window.

■ You can select displayed items in the Waveform window from analog data only, marker data only, or analog and marker 
data.

■ To remove waveform data from the Waveform window, select Edit > Clear from the menu bar.

■ You can select the vertical and horizontal units from the following using the Display Properties dialog box.

■ Vertical units – Voltage or Normalized Value

■ Horizontal units – Points or Time

1. This is an example of Graphic display 
format. Analog data and markers for 
Ch1 and Ch 2 are displayed.

2. You can edit the waveform data 
between two cursors.

3. This is an example of Table display 
format.
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Interface and Display
Settings Window
Use the Settings window tabs to quickly access the Level (Ch 1, Ch 2, Ch 3, and Ch 4), Timing, Run Mode, Trigger, Event, 
or DC Output parameters. You can also use the front-panel buttons for selecting frequently accessed parameters, such as 
amplitude, offset, marker high/low, or sampling rate. See page 20 for details about accessing menus.

Channel (Ch n) Page 

Quick Tips

■ Each channel has independent output on/off control. When the output status of Ch n is set to On, both analog output and 
marker output are enabled.

■ When Direct Output is set to On, filter and offset settings become inactive. The analog bandwidth setting range will 
change.

■ You can use Add Input when Direct Output is set to Off. If Direct Output is selected, Add Input is disabled.

■ For Waveform Rotation, see page 62.

1. To enable a channel output, click the 
Output On button.

2. You can set parameters for amplitude, 
offset, filter, and marker.

3. You can add an external signal to each 
channel analog output.

4. Select Direct Output On and Off.

5. When the instrument is in the 
non-sequence mode, you can select the 
output waveform data using the Output 
Waveform field. Click the waveform list 
icon to display the Waveform List dialog 
box.

6. You can set phase shift or delay for 
each analog output signal when the 
instrument is in the non-sequence 
mode.

1

42

3

5

6

26 AWG5000 Series Quick Start User Manual

Download from Www.Somanuals.com. All Manuals Search And Download.



Interface and Display
Digital Output

Quick Tip

■ Each channel has independent output on/off control. When the output status of Ch n is set to On, both analog output and 
digital output are enabled.

1. The AWG5002/AWG5012 Option 03 
supports digital data output. 

The SMB connectors for 14 bit digital 
data output are present for Ch 1 and 
Ch 2 on the rear panel.

2. You can set the output parameters as 
follows:

■ Digital Amplitude/Offset

■ Digital High/Low

The digital output levels are fixed as 
follows:

■ –1.0 V to +2.7 V, into 50 Ω

■ 0.01 V resolution

3. Digital High/Low is selected in this 
example.

4. Click the Output On button to enable the 
channel output.

013 12 11 10 9 8 7 6 5 4 3 2 1

~100-240 V
47-63 Hz

560 Watts

To avoid electric shock
the power cord protective
grounding conductor
must be connected to
ground. No operator
serviceable components
inside. Do not remove
covers. Refer servicing
to qualified personnel. 

 WARNING!

LINE
OUT

PARALLEL PORT

COM 1 VIDEO

KEYBOARD

MOUSE

To enable or disable the LAN, see 
enabling your LAN and connecting to a network 

in your manual.

LPT

MIC

LINE
IN

USB

Ch 1 Digital Data OutCh 2 Digital Data Out
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Ch 2
Add Input

Ch 1
External

Clock Input
Oscillator

Output
Reference

Clock Input
10 MHz

Reference Output

0.8 V p-p
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1 V Max
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3 V Max
50
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Interface and Display
Timing Page

Quick Tips

■ The Sampling Rate can be set when the internal clock source is selected and one of the following conditions is met:

■ Internal is selected as the reference source.

■ External is selected as the reference source and Fixed is selected as the external reference type.

■ The arbitrary waveform generator accepts a 10 MHz, 20 MHz, or 100 MHz frequency signal as a Fixed external 
reference source. 

■ You can set the Multiplier Rate when the Clock Source is set to Internal, the Reference Source is set to External, and 
the External Reference Type is set to Variable.

■ Refer to the online help for the range of each parameter in the Timing page.

1. Sets Sampling Rate.

2. You can set Repetition Rate when the 
Run mode is other than Sequence.

3. You can select Clock Source (Internal 
or External).

■ If External is selected, the clock 
signal from External Oscillator 
Input is used.

■ If Internal is selected, the clock sig-
nal is generated internally.

4. Divider Rate can be set when the Clock 
Source is set to External.

5. You can select the Reference Source 
(Internal or External).

Reference Source is selectable only 
when the Clock Source is set to Inter-
nal.

6. You can select the External Reference 
Type (Variable or Fixed).

This parameter is selectable only when 
the Clock Source is set to Internal and 
the Reference Source is set to Exter-
nal.

1 5 63
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Interface and Display
Run Mode Page

Quick Tip

■ The arbitrary waveform generator supports the following four run modes:

■ Continuous – A continuous waveform is output.

■ Triggered – A waveform is output once when the instrument receives a trigger signal. The instrument will wait for 
the next trigger signal after outputting the waveform.

■ Gated – A waveform is output only when a gate signal is asserted. A continuous waveform is output while the gate 
signal stays asserted.

■ Sequence – Multiple waveforms can be output in the order specified in the sequence. 

1. Select a Run mode.

2. In the Triggered or Gated mode, you 
can select the output value while the 
instrument is in the waiting-for-trigger 
state. 

■ First – Sets the output level to the 
first value of the waveform

■ Last – Sets the output level to the 
last value of the waveform

1

2
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Interface and Display
Trigger Page

Quick Tips

■ Trigger parameters control the signal outputs of the instrument. Trigger parameters cannot be set if Continuous is 
selected in the Run Mode.

■ You can also control the trigger by pushing the front-panel Force Trigger button in addition to a selected signal as the 
trigger source.

1. You can select Trigger Source (Internal 
or External). The default is External.

2. If External is selected, Trigger Level, 
Trigger Slope, and Trigger Impedance 
can be set.

■ Level – Sets external trigger level.

■ Slope – Determines whether the 
instrument finds trigger point on 
the rising edge or the falling edge 
of the signal.

■ Impedance – Specifies external 
trigger impedance (1 kΩ or 50 Ω).

3. If Internal is selected, internal trigger 
Interval can be set.

1
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Interface and Display
Event Page

You can use the Event page when the Run mode is Sequence.

Quick Tips

■ Event Jump can change the sequence order using an event signal. 

■ Jump timing is applied to both Event Jump and Force Jump. See page 67 for jump in sequence.

■ You can also use the front-panel Force Event button to generate an event signal internally.

DC Output Page

1. Sets external event input threshold 
level.

2. Selects the polarity of external event 
input signal (Positive or Negative).

■ Positive – Jump will occur when 
the instrument receives a positive 
pulse.

■ Negative – Jump will occur when 
the instrument receives a negative 
pulse.

3. Sets jump timing (Async or Sync).

■ Async – Jump will occur immedi-
ately.

■ Sync – Jump will occur after the 
waveform is generated.

4. Sets event input impedance (1 kΩ or 
50 Ω).

1. The arbitrary waveform generator has 
four lines of DC output.

The level of each output can be set 
independently.

2. The output state (On or Off) of the DC 
output is common to all DC output chan-
nels.

1 2 3 4
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Interface and Display
Default Setup
Push the front-panel Factory Default button to recall the factory default settings.

Instrument Settings at Power-on
You can select the instrument settings that are restored when you power on the instrument.

1. To quickly return to the factory default 
settings, push the front-panel Factory 
Default button.

2. When the instrument setups are modi-
fied, a confirmation dialog box appears. 
Click Yes to open a dialog box to save 
the setups.

3. You can also recall the factory default 
settings from the File menu.

1

2

3

Select System > Preferences... to display the 
Preferences dialog box. You can select the 
power-on setups from the following:

1. Factory Default – The factory default 
settings are always restored when the 
instrument is powered on.

2. Last Used File – Restores the setups 
that were saved or recalled last time.

3. User Default File – A specified setup file 
is always restored when the instrument 
is powered on.

4. Click the icon to display a dialog box to 
select the setup file.

This icon is enabled when User Default 
File is selected.
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Using the File Menu
Using the File Menu
Use the File menu for basic file operations such as saving/recalling instrument setups or importing/exporting waveform 
data. You can also use the File menu for standard Windows operations such as loading the most recent setup files.

The following menu items are provided in the File menu. For a complete description of each menu command, refer to the 
instrument online help system.

Quick Tip

■ You can also shut down the instrument by pushing the front-panel power button (On/Standby switch) while the 
application is running. When the power button is pushed, a dialog box asks you whether to save current setups. If you 
select Yes, the current setups are preserved and then the instrument will start the shutdown process.

1. Recalls factory default setups. 
See page 32.

2. Opens a dialog box to load an instru-
ment setup.

3. Saves (Overwrites) an instrument 
setup.

4. Saves an instrument setup assigning a 
new setup file name.

5. Use these commands to import wave-
form data.

6. Exports waveform data to a file for use 
with other applications.

7. A list of setup files you accessed 
recently is displayed here.

8. The application closes.

9. The application closes and then the 
instrument shuts down.
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Using the File Menu
Saving an Instrument Setup
Use the following steps to save an instrument setup:

Quick Tips

■ If a setup file contains Integer format waveform(s), the file size is reduced. For more information about waveform data 
format (Real or Integer), refer to the online help.

■ To change the waveform format in the Waveform, Waveform List, or Settings window, you can use the Waveform 
Properties dialog box. See page 56.

1. Select File > Save File to overwrite the 
existing instrument setup with an 
updated setup file.

2. To save the current setup to a new 
setup file, select File > Save File As... 
or push the front-panel Save button.

3. Select a location where you want to 
save the setup.

4. Type a file name or use the default 
name. 

5. Click Save.

2
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Using the File Menu
Recalling an Instrument Setup
You can recall an instrument setup from the File menu or from Windows Explorer.

Quick Tips

■ The arbitrary waveform generator uses a setup file that has an extension .AWG. Only .AWG files are displayed on the 
Open File dialog box by default.

■ Once you recall a setup, the instrument retains the setup until you execute Save File or Save File As.... If you select 
Save File after changing the instrument parameters, the instrument setup file will be automatically overwritten.

■ Output status including DC Output becomes Off when a setup file is recalled.

1. Select File > Open File... to open the 
Open File dialog box.

You can also open the Open File dialog 
box by pushing the front-panel Open 
button.

2. Select a setup file.

3. Click Open.

NOTE. The AWG5000 series and AWG7000 series setup files are compatible each other. However, if the parameter 
value(s) of an instrument setup file are out of range, a warning message is displayed. In this case, out of range parameter 
values are set to the default values.
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Using the File Menu
Importing Waveform Data
Data import functions allow you to use waveform data created outside the arbitrary waveform generator. You can import 
data to create a new waveform or to replace existing waveform data.

The arbitrary waveform generator supports the following file formats:

■ *.AWG file created by Tektronix AWG5000 series and AWG7000 series

■ The following file formats created by Tektronix arbitrary waveform generators such as AWG400/500/600/700 series:

■ *.PAT

■ *.SEQ

■ *.WFM

■ *.TFW file created by Tektronix AFG3000 series arbitrary/function generator

■ *.DTG file created by Tektronix DTG5000 series data timing generator

■ *.WFM or *.ISF file created by Tektronix TDS/DPO series oscilloscope

■ Text file (*.TXT)

Refer to the online help system for more information about file import.

1. Select File > Import from File... to 
display the Import from File dialog box.

2. Select the file format that you want to 
import.

3. Click OK.

The File Import dialog box, such as 
shown in step 4, is displayed.
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Using the File Menu
4. Select a file to import.

5. Select an import action in the Operation 
frame.

■ Set to
Select the channel and index num-
ber. The imported waveform data will 
be assigned to the specified position.

■ Insert before
The imported waveform data will be 
inserted before the specified cell of 
the sequence. When the run mode is 
non-sequence, this parameter is dis-
abled.

■ Create only
The imported waveform will be 
added to the Waveform List window.

■ Overwrite
Specified existing waveform data is 
overwritten. 

6. If the imported waveform data contains 
information on sampling rate, amplitude, 
or offset, you can select the attribute for 
the waveform using the Change H/W 
Setup.

For example, if you check the Sampling 
Rate check box, the sampling rate will be 
modified to reproduce the same signal 
as the imported data.

7. Click Open.

When the import file format is *.AWG, 
*.DTG, or *.TXT, a corresponding dialog 
box is displayed.

When the import file format is other than 
*.AWG, *.DTG, or *.TXT, the selected 
file is imported and the waveform 
name(s) are listed in the Waveform List 
window.
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Using the File Menu
8. If the file format is Tektronix AWG5000 
series or AWG7000 series, the AWG 
File Import dialog box is displayed.

Select a waveform to import.

9. Click OK. The selected waveform is 
imported.

You can select multiple waveforms.

10. If the file format is Tektronix DTG5000 
series, the DTG File Import dialog box is 
displayed.

11. Assign each bit of imported DTG5000 
series block data (DTG bits) to AWG 
bits.

8
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Using the File Menu
Quick Tips

■ When creating a new waveform, the name of the imported file will be the name of created waveform.

■ By executing the file import function, the existing waveform is changed to be the same length as the imported file.

12. If text file format is selected, the Text 
File Import dialog box is displayed.

Select the file format using the Format 
frame.

13. Select the normalize option using the 
Normalize frame.

■ None
The waveform data is not normal-
ized.

■ Fit to DAC Range, Preserve Offset
The waveform data is scaled relative 
to 0 (zero).

■ Fit to Full DAC Range
Minimum value goes to –1.0 in 
normalized value and the maximum 
value goes to +1.0 in normalized 
value.

14. This dialog box is displayed when you 
execute import and the same name 
waveforms already exist. Select Yes or 
Yes to All if you want to replace the 
waveform(s).
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Using the File Menu
Exporting Waveform Data
The arbitrary waveform generator can export waveform data to a text file for use with other applications.

Quick Tips

■ You can select one of the following file formats for export:

■ Text (*.txt)

■ Text – Digital 14 bits (*.txt)

■ In the sequence mode, you can also open the dialog box from the pop-up menu displayed by right-clicking on a cell.

1. Select the waveform data for export. 
You can select a waveform from the 
Waveform List window.

2. Select File > Export Waveform to 
File... to open the Export dialog box.

Select a location to save the waveform 
data in Save in box.

3. The waveform name you selected in the 
Waveform List window is displayed.

4. Click Save. You can export the selected 
waveform data as a file format .txt.
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Using the Edit Menu
Using the Edit Menu
Use the Edit menu to create a new waveform or modify an existing waveform.

1. Select Undo to cancel the last process.

Undo does not apply to cursor position, 
zoom, and scroll functions.

2. Select Redo to repeat the last process.

3. Opens the Standard Waveform dialog 
box.

4. Opens the Sequence Control Parame-
ters dialog box.

5. Opens the Cut or Delete dialog box.

In the sequence, Cut or Delete causes 
an immediate action.

6. Select Delete All Waveforms to delete 
all the waveform data in the setup file.

7. Clear removes contents of selected 
element(s) in the Sequence window. 
Remaining elements do not shift.

In the Waveform window, Clear 
removes the selected waveform data.

8. Opens the Copy dialog box.

In the sequence, Copy causes an 
immediate action.

9. Select Paste to copy the content of clip-
boad.

10. Opens various edit-related dialog 
boxes.

11. Opens the Marker related submenu.

12. Opens Waveform Properties dialog box.
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Using the Edit Menu
Creating a Standard Waveform
You can create a new waveform using the standard waveform dialog box.

1. Select Edit > Standard Waveform... to 
open the Standard Waveform dialog 
box.

2. Use Function to select a waveform 
type. You can select a waveform from 
Sine, Triangle, Square, Ramp, Gaus-
sian Noise, and DC.

3. Use Timing to set parameters for 
Frequency, Waveform Length, and 
Cycle.

4. Select Auto or No Change in Sampling 
Rate.

■ Auto
Sampling rate and waveform length 
are automatically set to appropriate 
values.

■ No Change
Sampling rate is not changed. You 
can select any two parameters from 
frequency, waveform length, and 
cycle. The remaining parameter will 
be calculated automatically.

5. A waveform is displayed on the Preview 
screen.
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Using the Edit Menu
6. Use Level to set parameters for Ampli-
tude/Offset or High/Low.

7. Use Option to select the amplitude/ 
offset settings. This frame is displayed 
when you set the vertical units to 
Voltage.

If you set the vertical units to Normal-
ized Value, this frame is disabled. Refer 
to page 59 for vertical units setting.

8. Select an edit action in the Operation 
frame.

■ Set to
Specifies the channel and index 
number. The created waveform is 
assigned to the specified position.

■ Insert before
The created waveform is inserted 
before the specified cell of the 
sequence. When this command is 
executed, the remaining data is 
shifted. When the Run mode is 
non-sequence, this parameter is dis-
abled.

■ Create only
Creates a new waveform, but the 
waveform is not loaded. Enter the 
waveform name in the Waveform 
Name box. The created waveform is 
listed in the Waveform List window.

■ Overwrite
Specified existing waveform data is 
overwritten. When you select Over-
write, a waveform currently being 
loaded is displayed in the Target 
Waveform Name box. The Waveform 
Name box is disabled.

9. Click Execute to create a waveform.
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Using the Edit Menu
Using Cut, Copy, Paste and Delete (Waveform Window)
You can cut or copy specified area to the instrument’s internal clipboard. Cut or copied data can be pasted to a specified 
position in either Graphic or Table mode. When executing these operations, items and range are usually specified.

■ You can select item(s) to cut or copy from the following:

■ All – Cut or copy all items

■ Ch n Analog data

■ Ch n Marker 1 data/Marker 2 data

■ You can specify the range to cut or copy from the following:

■ All – Cut or copy all data.

■ Between Cursors – Cut or copy the area between the two cursors.

■ Selected (Table mode only) – Select the cut or copy area by dragging the mouse in the Table mode. In this case, 
the Cut dialog box automatically checks Selected in the Range field.

Example of Cut (Waveform Window)

You can execute Cut operation for both Graphic mode and Table mode in the Waveform window.

NOTE. The internal clipboard resides in the instrument application software. It is different from Windows clipboard. You 
cannot transfer data from other applications like Microsoft Excel into the instrument clipboard. Data transfer from other 
applications is possible using the import/export functions.

1. Select the item(s) you want to cut.

1
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Using the Edit Menu
Quick Tips

■ Delete is the same as Cut except that Delete does not change the contents of the internal clipboard.

■ If all items are cut or deleted, the waveform length will be shortened accordingly.

2. Specify the range using cursors.

3. Select Edit > Cut... to open the Cut 
dialog box. You can also select Cut from 
the pop-up menu displayed by 
right-clicking in the Waveform window.

If you need to change the Item or Range 
settings, use this dialog box.

4. Click OK.

5. The selected portion of the waveform is 
cut. The waveform is shifted and the 
default value will be filled.

NOTE. If part of items are cut or deleted, the 
waveform length will not be shortened. The 
data is shifted. The portion after the shifted 
area will be filled with default value.
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Using the Edit Menu
Defining a Sequence
It is sometimes necessary to create long waveform files to fully implement a DUT test. Where portions of the waveforms 
are repeated, a waveform sequencing function can save you a lot of memory-intensive waveform programming.

Sequencer is used for mainly the following two purposes:

■ Output longer waveform than hardware memory

■ Change the output waveform quickly (such as ATE applications)

Quick Tips

■ If Sequence is selected in the Run mode, the sequencer executes the sequence definition. Sequence definition 
consists of a series of sequence elements. Each sequence element has the following information:

■ References to the waveform for each channel

■ Sequence control parameters (Wait, Repeat, Event Jump To and Go To)

■ Sequence is executed in turn from the first element (Element Index = 1) to the last element. If an element has Jump To 
or Go To, the sequencer follows that definition.

1. To define a sequence, select Edit > 
Sequence Control Parameters... to 
open the dialog box.

2. The sequencer will wait for the trigger 
before generating a waveform if Wait 
Trigger is checked.

3. A waveform can be repeated if the 
Repeat Count is specified for each 
element of the sequence.

4. Event Jump To changes the sequenc-
ing of the waveform by the external 
event.

See the Quick Tips below for supported 
event signals.

5. If you specify Go To target for each 
sequence element, the sequencer jumps 
to the element specified by Go To target 
immediately after generating the wave-
form specified in a sequence element. 

If the Go To target is not specified, the 
sequencer moves on to the next element.

1

2

5

4

3

46 AWG5000 Series Quick Start User Manual

Download from Www.Somanuals.com. All Manuals Search And Download.



Using the Edit Menu
■ The following signals are supported as an event:

■ A signal applied to the front-panel Event Input connector

■ When the front-panel Force Event button is being pushed

■ Remote command

NOTE. There are two sequencer modes in the arbitrary waveform generator to execute the created sequence: The hard-
ware sequencer mode and the software sequencer mode. Refer to the online help for details about the difference between 
the hardware and software sequencer modes.
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Using the Edit Menu
Editing a Sequence
The following commands are provided for sequence edit:

Clear. Clear removes the contents of selected element(s). Unselected elements do not shift. You can clear multiple 
non-contiguous elements.

Copy, Paste-Insert and Paste-Replace. You can copy or paste data on one or more contiguous elements. The data 
in the clipboard will be inserted or replaced at the specified position of the sequence. If Paste-Insert is executed, the exist-
ing data is shifted.

Cut Example (Sequence Window)

You can do a Cut or Delete on one or more contiguous elements.

Quick Tip

■ For more information on the edit commands for sequence, refer to the online help.

1. Select the element(s) to cut. In this 
example, Index number 2 is the target of 
Cut.

NOTE. Cut and Delete can be done by the units 
of element.

2. Select Cut from the Edit menu or the 
pop-up menu.

3. Cut is executed and the remaining data 
in the sequence are shifted.

NOTE. Cut data is placed in the clipboard. 
Deleted data is removed from the sequence 
and cannot be recovered.
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Using the Edit Menu
Using Set Waveform and Insert Waveform
You can insert or replace a waveform in the Sequence window.

■ Set Waveform – Use to assign or replace the selected waveform at the specified position in the Sequence window.

■ Insert Waveform – Use to insert the selected waveform at the specified position in the Sequence window.

Quick Tip

■ You can select and drag a waveform from the Waveform List window to the Sequence window. This is an easier way 
to set or insert a waveform to the Sequence window.

1. Right-click on the Sequence window 
cell you want to set or insert a waveform 
to display the pop-up menu, and then 
select Set Waveform... or Insert 
Waveform...

You can also access these functions 
from the Edit menu.

2. Select a waveform you want to set or 
insert from the displayed list.

3. Click OK to set or insert the waveform.
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Using the Edit Menu
Using Paste-Insert and Paste-Replace
You can insert or replace waveform data in the clipboard in the Waveform window or Sequence window. The following 
example shows a Paste-Insert operation in the Waveform window.

Quick Tips

■ Executing Paste-Insert will shift the existing data.

■ Executing Paste-Replace will not shift the existing data.

1. Select the Ch 2 waveform.

2. Select the range of copy using the 
cursors.

3. Select Edit > Copy... to display the 
dialog box and then specify Item and 
Range to copy.

4. Click OK.

5. Select the Ch 1 waveform.

6. Specify the position to Paste-Insert the 
waveform data.

7. Select Edit > Paste-Insert to insert the 
copied data to the specified position on 
the Ch 1 waveform.
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Using the Edit Menu
Using Rename
You can change the waveform name in the Waveform List window.

Using Other Edit Menu Commands
Scale. You can scale the specified range of analog data using Scale from the Edit menu.

1. Select a waveform in the Waveform List 
window, and then select Edit > 
Rename from the menu bar to open the 
Rename dialog box.

2. The waveform name is displayed.

3. Enter the new waveform name in the To 
field.

2

3

1

1. Vertical scale origin and scale factor 
can be set. The scale factor does not 
have the units.

2. For item and range, refer to page 44.
1
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Using the Edit Menu
Offset. You can add constants to the specified range of analog data using Offset from the Edit menu.

Invert. Data values in the specified range can be inverted using Invert from the Edit menu.

1. Offset can be set by voltage or normal-
ized value.

2. For item and range, refer to page 44.

1. For item and range, refer to page 44.

For analog data, a positive value will 
become negative. For marker data, low 
(0) becomes high (1).
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Using the Edit Menu
Horizontal Shift/Rotate. You can shift or rotate the specified range of waveform data horizontally using Shift/Rotate 
from the Edit menu.

Quick Tips

■ Horizontal Rotate is used to check if the waveform data is connected smoothly from the end of the first waveform to 
the beginning of the second waveform. This is especially useful when the waveform is looped by the sequencer.

■ Horizontal Shift/Rotate is applied for analog data and marker.

Set High/Low. You can set the specified range of marker data to high or low using Set High/Low from the Edit menu.

1. Select Mode (Shift or Rotate).

2. Enter the value for the Shift or Rotate 
range.

3. Linear or Quadratic interpolation can be 
selected for fractional shift or rotation.

4. For item and range, refer to page 44.

1. Select High or Low.

2. For item and range, refer to page 44.
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Using the Edit Menu
PRBS. You can replace a specified range of waveform data with a PRBS pattern.

Set Pattern. You can fill the specified area of marker data with a selected digital pattern.

1. Select a PRBS pattern.

2. Select a Mark Density.

3. Invert can be set to On or Off.

4. For item and range, refer to page 44.

1. You can enter a pattern directly, or load 
a text file from the internal hard drive or 
an external memory device.

The maximum length of a bit pattern is 
1000.

2. For item and range, refer to page 44.

If multiple items are specified as a 
target for Set Pattern, the same data will 
be filled in for all items.
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Using the Edit Menu
Clock Pattern. You can fill a specified area of marker data with the 1010 clock pattern.

Binary Counter. You can fill the specified area of marker data with binary counter pattern.

1. Use this dialog box to change the Item 
or Range.

1. You can select the direction (Up counter 
or Down counter).

The up counter begins from all 0, and 
the down counter begins from all 1.

2. For item and range, refer to page 44.
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Using the Edit Menu
Waveform Properties. You can confirm or change properties of waveform data using the Waveform Properties dialog 
box.

1. Select a waveform in the Waveform List 
window, and then select Edit > Wave-
form Properties... from the menu bar 
to display the dialog box.

You can also access this dialog box 
from the pop-up menu displayed by 
right-clicking in the Waveform List 
window.

2. You can confirm or change the wave-
form length.

3. You can confirm or change the wave-
form data type (Real or Integer).
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Using the View Menu
Using the View Menu
Use the View menu to control the arbitrary waveform generator screen display. The choices are as follows:

1. Opens the Go To... dialog box.

2. You can select one of these zoom func-
tions. See page 61.

3. Check to display these control windows 
and status bar.

4. Opens the Display Properties dialog 
box.

5. Check to display the Remote Command 
Bar. See page 18.
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Using the View Menu
Using Go To Dialog Box
This dialog box is used to move to a specified position in the sequence, or to specify an index number to go to.

Quick Tip

■ You can also use the Go To dialog box in the Waveform List window.

1. Select View > Go To... in the Sequence 
window to display the Go To dialog box.

Select the Go To target or enter an 
index number in the Value field.

You cannot specify the Go To target 
using a parameter of time.

2. Click OK. The display will shift to the 
specified position.

3. Select View > Go To... in the Waveform 
window to display the Go To dialog box.

Select the Go To target or enter Points 
or Time value in the Value field.

4. Click OK. The display will shift to the 
specified position.
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Using the View Menu
Using Display Properties Dialog Box
You can configure the appearance of waveform edit and sequence edit windows of your arbitrary waveform generator.

1. Select View > Display Properties... to 
display the Display Properties dialog 
box.

Click the Waveform Window tab.

2. You can select the Waveform window 
display format (Graphic or Table).

3. When Overlay is specified, analog data 
from multiple channels can be 
displayed overlaid.

4. When Graphic is specified, you can 
turn the Grid On and Off.

5. When Table is specified, you can select 
the table display format from the 
following:

■ Binary

■ Hex

■ Voltage

■ Normalized Value

6. You can select displayed items for each 
channel in the Waveform window.

7. You can select the vertical units.

8. You can select the horizontal units.

The vertical and horizontal units set-
tings are common to all channels.
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Using the View Menu
9. Click the Sequence Window tab.

10. Select Graphic or Table for the 
Sequence window display format. The 
display format is common to all chan-
nels.

11. If Graphic is specified, you can select 
the display format (Thumbnail or 
Waveform Name). 11

10
9
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Using the View Menu
Using Zoom
Use the Zoom function to magnify or reduce a waveform display. The choices are as follows:

1. Zoom In
Use Zoom In to magnify a waveform 
horizontally and vertically at the same 
time.

2. Horizontal Zoom In
Use Horizontal Zoom In to magnify a 
waveform horizontally.

3. Vertical Zoom In
Use Vertical Zoom In to magnify a 
waveform vertically.

You can select the vertical scale defini-
tion when zooming vertically. Use the 
Preferences dialog box. See page 69.

4. Zoom Out
Use Zoom Out to return the previous 
zoom factor. You can use Zoom Out only 
after the waveform is magnified.

5. Fit to Window 
Use Fit to Window to fit the waveform 
in the window and restore the waveform 
to its state before the first zoom in. You 
can use Fit to Window only after the 
waveform is magnified.
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Using the Settings Menu
Using the Settings Menu
Use the Settings menu to control the display items on the Settings window.

Quick Tips

■ The Waveform Rotation can be set independently for each channel.

■ Analog Phase – Can be set by degree (°).

■ Analog Delay – Can be set by time or points.

■ The Waveform Rotation setting does not affect the Waveform window display.

1. Click one of these commands to make 
the corresponding page of the Settings 
window active.

2. These menu items allow you to select 
Analog, Marker, and Digital Ampli-
tude/Offset or High/Low settings.

3. Select setting units for Waveform Rota-
tion. You can use the Channel page of 
the Settings window for parameter 
input.

4. Opens the Coupling dialog box.

5. If Analog (Marker or Digital) Ampli-
tude/Offset is selected, the parameters 
for Amplitude and Offset are displayed 
in the Channel page of the Settings 
window.

6. If Analog (Marker or Digital) High/Low is 
selected, the parameters for Analog 
(Marker or Digital) High and Analog 
(Marker or Digital) Low are displayed in 
the Channel page of the Settings 
window.
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Using the Settings Menu
Channel Coupling
You can change the parameter values for multiple channels at a time. This function is called Channel Coupling.

Quick Tips

■ Ch 1 –>Ch 2, Ch 3, Ch 4 means that Ch 1 parameters are coupled with Ch 2, Ch 3 and Ch 4 parameters. With the 
Channel Coupling in the On state, the Ch 1 parameters are applied to the instrument hardware settings of the other 
three channels. You cannot select parameters for channel coupling in the Channel page of the Settings window. The 
disabled parameters are grayed out.

■ The following parameters are excluded from channel coupling:

■ Channel skew

■ Output waveform

■ Sequence waveform

■ External signal add function

■ Waveform Rotation

■ Marker Delay

■ Parameters that are not related to the output signal, such as marker display on/off

1. Select Settings > Coupling... to open 
the Coupling dialog box.

You can also open this dialog box from 
the pop-up menu displayed by 
right-clicking on the Channel page of 
the Settings window.

2. Select a coupling method.

Ch 1 –> Ch 2 and Ch 3 –> Ch 4 means 
that Ch 1 and Ch 2, and Ch 3 and Ch 4 
are coupled, respectively.

3. Select Ch 1 –>Ch 2, Ch 3, Ch 4 to 
couple the Ch 1 parameters with Ch 2, 
Ch 3, and Ch 4 parameters.
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Using the Tools Menu
Using the Tools Menu
Use the Tools menu to perform the math operations or select normalize option settings.

Math Waveforms
You can use the Math dialog box to perform mathematical operations on the waveform you are editing. The analog data of 
two waveforms can be added, subtracted, or multiplied. The created waveform data can be added to the Waveform List.

Quick Tips

■ A new waveform will be created as the result of waveform math operation. For the marker data, the data of the first 
operand waveform will be copied to the new waveform.

■ The math operation is executed for all analog waveform data.

■ If the length of two waveforms is not the same, the length of the result is the same as the length of the shorter waveform. 
The beginning part of the longer waveform is used for the calculation.

1. Select Tools > Math... to display the 
Math dialog box.

2. You can enter a waveform name in the 
New Waveform field. The default wave-
form name is Untitled1.

3. Select a waveform from the waveform 
list. Click the icon to display the Wave-
form List dialog box.

4. Select a math operator.

5. If Update Image is checked, the calcu-
lation results will be reflected on the 
graph.

6. Click OK to add the new waveform to 
the Waveform List window.
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Using the Tools Menu
Normalize Option
You can select normalize options when analog data is normalized. Normalize is executed for the entire analog waveform 
data.

Select one of the following options from the 
Tools menu:

1. Fit to DAC Range, Preserve Offset
The waveform data is scaled relative to 
0 (zero).

2. Fit to Full DAC Range
Minimum value goes to –1.0 in normal-
ized value and the maximum value goes 
to +1.0 in normalized value. 
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Using the System Menu
Using the System Menu
The System menu provides access to the instrument system configuration such as signal generation control, instrument 
calibration, and instrument diagnostics. You can also set the user preferences such as power-on settings or LCD brightness 
using the System menu. 

Quick Tip

■ Selecting Run from the System menu causes the same effect as pushing the front-panel Run button or the Status Bar 
Run button.

Channel Skew Adjustment
The channel skew adjusts the skew (delay) of each channel output.

1. Select System > Run or Stop to control 
the signal generation start and stop. 
See page 17 for Run State.

2. Click one of these commands to open 
the corresponding dialog box.

1

2

Select System > Channel Skew... to open the 
Channel Skew dialog box.

1. You can adjust the skew for each 
channel independently. This adjustment 
applies to analog output and marker 
output.

2. Adjusting the skew value will update the 
dialog box display.
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Using the System Menu
Using Force Jump To Dialog Box
Force Jump allows you to jump to a position that you choose. This function is used in sequence mode.

Quick Tips

■ The arbitrary waveform generator has an Event Jump function which changes the sequence using an event signal. Use 
the Event page of the Settings window to set parameters for Event Jump. See page 31 for the Event page.

■ Use the Sequence Control Parameters dialog box from the Edit menu to set the jump target of Event Jump. 
See page 46 for the dialog box.

■ Force Jump is similar to Event Jump. In the case of Force Jump, you must specify the jump target explicitly by using 
the Force Jump To dialog box.

■ Force Jump is independent from Event Jump. Force Jump can be executed regardless of the Event Jump setting.

1. Select System > Force Jump To... to 
open the Force Jump To dialog box.

2. Specify a jump target or select Index 
No.

3. When Index No is selected as jump 
target, enter the index number using the 
Value: field.

4. Click Jump Now to change the wave-
form output to the position specified by 
jump target.

5. Click Close to close the dialog box.
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Using the System Menu
Setting GPIB/LAN

Quick Tip

■ The following operations cannot be performed through a GPIB or LAN connection:

■ Editing a waveform

■ Changing size or name of waveform

■ Converting the waveform format

■ Importing waveform data from the AWG5000 series and AWG7000 series setup (*.AWG) file

■ Importing a Tektronix DTG5000 series file (*.DTG)

■ Importing a Tektronix AWG400/500/600/700 series SEQ file

■ Exporting a file

Select System > GPIB/LAN Configuration to 
open the GPIB/LAN Configuration dialog box.

1. Set the instrument GPIB bus communi-
cation:

■ Talk/Listen – Select this mode to 
remotely control the instrument from 
an external host computer.

■ Off Bus– Select this mode to discon-
nect the instrument from the GPIB 
bus.

2. The instrument supports the following 
two LAN connections:

■ VXI-11

■ Raw Socket
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Using the System Menu
Setting the User Preferences

Select System > Preferences... to open the 
Preferences dialog box.

1. Startup – Select a power-on setting. 
See page 32.

2. LCD Brightness – Set the LCD brigt-
ness.

3. Remote Command Log – You can 
record the sequence of GPIB 
commands you used with your instru-
ment.

4. Fit to Window Based On – Select the 
vertical scale setting when you use the 
Zoom Fit function.

■ H/W Output Range
Vertical scale is set based on the 
instrument hardware limitation.

■ Waveform Data
Vertical scale is set based on the 
waveform data.

5. Hold – Select which parameter is held 
when the effective waveform length is 
modified.

■ Sampling Rate

■ Repetition Rate

6. User Online Help Language – Select a 
language in which to display on the 
User Online Help.
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Using the System Menu
Option Installation
Use the Option Installation dialog box to enable the upgrades that you purchased from Tektronix for your instrument. For 
the most current list of upgrades, go to www.tektronix.com or contact your local Tektronix representative.

1. Select System > Option Installation... 
to open the Option Installation dialog 
box.

2. Click Continue to open the second 
dialog box.

Enter the Option Installation Key pro-
vided by Tektronix, and follow the 
on-screen instructions to install the 
option.

NOTE. After entering the option key, you must restart the instrument application to activate the option.
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Tutorials
Tutorials
The examples in this section show how to use your instrument to do common arbitrary waveform generator tasks. These 
examples use the dual-channel model.

Creating and Editing a Standard Waveform

1. Recall the default setup.

2. Select Continuous from the Run Mode 
page of the Settings window.

3. Use the Standard Waveform dialog box 
to create the square waveform shown 
below:

■ Waveform Length: 960 points

■ Cycles: 5

■ Amplitude: 1.0 Vp-p

■ Offset: 0.5 V

4. Set the waveform created in step 3 to 
Ch 1.

5. Assign the waveform name 
“Ch1-Square” to the waveform.

6. Use the Standard Waveform dialog box 
to create the sine waveform shown 
below:

■ Waveform Length: 1024 points

■ Cycles: 3

■ Amplitude: 1.0 Vp-p

■ Offset: –0.5 V
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Tutorials
7. Set the waveform created in step 6 to 
Ch 2.

8. Assign the waveform name “Ch2-Sine” 
to the waveform.

9. To edit analog waveform data, hide the 
Ch 1 and Ch 2 Marker data using the 
Display Properties dialog box.

10. Delete points from the end of the Ch 2 
waveform to make it the same length as 
the Ch 1 waveform.

Use cursors to set the range.

11. Ch 1 and Ch 2 waveforms have the 
same waveform length. You can now 
output the signal.

12. Save the setup.

7
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Tutorials
Editing a Sequence

1. Recall the default setup.

2. Select Sequence from the Run Mode 
page of the Settings window.

3. Select *Sine960 from the Predefined 
page of the Waveform List window, and 
set the waveform to the first cell of Ch 1 
sequence.

Refer to page 24 to learn how to assign 
an existing waveform to a cell in the 
sequence.

4. Select *Triangle960 from the 
Predefined page of the Waveform List 
window, and set the waveform to the 
second cell of Ch 1 sequence.

5. Create a sine waveform with the 
following attributes and set the wave-
form to the third cell of Ch 1 sequence.

■ Waveform Length: 960 points

■ Cycles: 5

■ Amplitude: 1.0 Vp-p

■ Offset: 0.0 V

■ Waveform Name: Sine-1

6. Select the first element in the Sequence 
window. The selected cell is high-
lighted.
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Tutorials
7. Set Wait Trigger to the index number 1 
using the Sequence Control Parame-
ters dialog box. This makes the 
sequence wait a trigger before gener-
ating the first element.

8. Set Repeat Count to 5 at the index 
number 2. This makes the sequence 
repeat the second element five times.

9. Set Go To target to 1 at the index 
number 3. This makes the sequence 
jump to index number 1 after generating 
the index number 3.

10. Click the Run button to confirm that the 
sequence works properly. The anima-
tion window next to the Run button will 
be activated when the instrument is in 
the running state.

This screen image shows Table mode is 
selected in the Sequence window.
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